Vraag Hoe libpq-dev te installeren op Centos 5.5


Om een ​​webtoepassing op basis van postgresql te ontwikkelen, moet ik libpq op mijn centos installeren.

Ik kan het installeren met "apt-get install libpq-dev" op ubuntu, maar ik kan het niet installeren op centen door "yum install libpq".

Wie kan mij vertellen hoe ik het moet installeren, bedankt!


44
2017-09-29 06:03


oorsprong




antwoorden:


Het pakket is gebeld postgresql-libs op Red Hat en afgeleide distributies.


46
2017-09-29 14:15



Nuttig antwoord. Dus veel antwoorden vertellen me libpq-dev installeren! - Albert.Qing


Ik moest dit gewoon op mijn CentOS 6-server installeren, omdat psycopg2 pg_config vereiste. Boo yah:

yum install postgresql-devel

Bijwerken

Als u nog steeds problemen ondervindt met pg_config, moet u dit mogelijk toevoegen aan uw PATH, bijvoorbeeld:

export PATH=$PATH:/usr/pgsql-x.x/bin

waar x.x uw versie is, zoals /usr/pgsql-9.2./bin.


69
2017-11-19 20:22



Dit werkte voor mij (ik had ook pg_config nodig om psycopg2 te installeren) - Tom Dalling
onthoud, als je een globale installatie probeert te doen (sudo pip psycopg2) om het aan het juiste pad toe te voegen. Werkte niet voor mij, zelfs niet na het leveren --install-option met pip install en toen besefte ik dat ik sudo pip installeerde. - matchew


Het is libpqxx:

Name       : libpqxx-devel
Arch       : x86_64
Version    : 2.6.9
Release    : 3.el5.rf
Size       : 1.4 M
Repo       : rpmforge
Summary    : Header files, libraries and development documentation for libpqxx.
URL        : http://pqxx.org/
License    : BSD
Description: This package contains the header files, static libraries and development
           : documentation for libpqxx. If you like to develop programs using libpqxx,
           : you will need to install libpqxx-devel.

U kunt het installeren vanaf rpmforge of Epel repo:

# yum install libpqxx-devel

7
2017-09-29 06:12



Nee, dat is een ander pakket. - Peter Eisentraut
xx middelen C++. - quanta
Het is het juiste antwoord - dba.in.ua