Vraag hoe op te lossen "send-mail: Autorisatie mislukt 534 5.7.14"


Ik probeer om e-mail alert te maken op ssh root login dus moest ik installeren ssmtp en mail nut.

Toen heb ik geconfigureerd ssmtp.conf bestand als volgt:

# Config file for sSMTP sendmail
# The person who gets all mail for userids < 1000
# Make this empty to disable rewriting.
        #root=postmaster
        #Adding  email id to receive system information
root = rootuser@gmail.com
# The place where the mail goes. The actual machine name is required no
# MX records are consulted. Commonly mailhosts are named mail.domain.com
        #mailhub=mail

mailhub = smtp.gmail.com:587

AuthUser=dmymail@gmail.com
AuthPass=plaintext password
UseTLS=YES
UseSTARTTLS=YES

# Where will the mail seem to come from?
rewriteDomain=gmail.com

# The full hostname

hostname = mailserver
# Are users allowed to set their own From: address?
# YES - Allow the user to specify their own From: address
# NO - Use the system generated From: address
FromLineOverride=YES

evenals revaliases als volgt:

# Format:       local_account:outgoing_address:mailhub
# Example: root:your_login@your.domain:mailhub.your.domain[:port]

root:rootuser@gmail.com:smtp.gmail.com:25

en ik krijg deze foutmelding:

send-mail: Authorization failed (534 5.7.14 https://support.google.com/mail/bin/answer.py?answer=78754 ni5sm3908366pbc.83 - gsmtp)
Can't send mail: sendmail process failed with error code 1

maar het werkte niet. Help me alsjeblieft om dit uit te zoeken


52
2017-10-10 17:09


oorsprong


mogelijk duplicaat van sSMTP Kan bericht niet verzenden met SMTP, externe mailserver - mailq
Kreeg deze fout gisteravond nadat deze een aantal maanden heeft gewerkt. - ceving
Na het uitvoeren van alle voorgestelde stappen is het nog steeds mislukt totdat ik gewoon mijn wachtwoord voor gmail.com veranderde, hoewel ik het juiste wachtwoord gebruikte ... misschien is het een nieuwe Google-beveiligingsmaatregel - Scott Stensland
@ceving wat was de remedie? Hoe heb je het opgelost? - 3kstc


antwoorden:


Het kan meer dan één stap duren om dit probleem op te lossen

  1. Neem de eerder genoemde stap. Log in op uw Google-e-mailaccount en ga vervolgens naar deze link: https://www.google.com/settings/security/lesssecureapps en stel "Toegang voor minder veilige apps" in op AAN. Test om te zien of uw probleem is opgelost. Als het niet is opgelost, zoals het niet voor mij was, ga dan verder met stap # 2.

  2. Ga naar https://support.google.com/accounts/answer/6009563 (Getiteld: "Wachtwoord onjuiste fout"). Deze pagina zegt: "Er zijn verschillende redenen waarom u een foutmelding" Wachtwoord onjuist "(534-5.7.14) zou kunnen tegenkomen wanneer u inlogt bij Google via apps van derden. In sommige gevallen zelfs als u uw wachtwoord correct invoert. "  Deze pagina geeft 4 suggesties om te proberen.

Voor mij werkte de eerste suggestie:

  • Ga naar https://g.co/allowaccess vanaf een ander apparaat dat u eerder hebt gebruikt om toegang te krijgen tot uw Google-account en volg de instructies.
  • Probeer opnieuw in te loggen vanuit de geblokkeerde app.

Er stonden nog drie suggesties op de pagina in stap # 2, maar ik heb ze niet geprobeerd, want nadat ik naar de geredigeerde link ging en de instructies volgde, begon alles te werken zoals het zou moeten.


73
2018-03-01 01:42



Optie 1. werkte voor mij - Patrick Forget
Ter informatie: u kunt dit voor uw hele bedrijf inschakelen als u google apps voor bedrijven gebruikt in de beveiligingsinstellingen. - Travis Reeder
+1, Optie 1 gevolgd door g.co/allowaccess werkte perfect. - greg_data
Heeft een paar minuten geduurd, maar ik heb ontdekt hoe ik het voor de gehele organisatie in Admin Console onder Windows kan inschakelen Veiligheid > Basis instellingen > Minder veilige apps > Toegang afdwingen ... wat voor meer verwarring "Geavanceerde beveiligingsinstellingen" in de titel aangeeft (hoewel ik geen link naar die pagina kon vinden via de geavanceerde beveiligingsinstellingen ...). Verward? Ik ook! - isapir


Dit werkte voor mij.

1) Log in op uw gmail-account.

2) Ga naar https://www.google.com/settings/security/lesssecureapps en schakel deze functie in.

3) Ga naar https://accounts.google.com/DisplayUnlockCaptcha en klik op Doorgaan.

Vervolgens kunt u uw extra e-mailadres verifiëren via uw Gmail-account.

Bewerken: in mijn geval heeft het geholpen om smtp.gmail.com te schrijven in plaats van smtp.gmail.com:587.


10
2017-12-29 03:27





Ik had hetzelfde probleem. Neem zeker de beveiligingsinstellingen van uw gmail-account door en schakel 'Toegang voor minder goed beveiligde apps' in op www.google.com/settings/security.

het zal dan op magische wijze beginnen te werken.


4
2017-10-14 17:45



Dit is nuttig en ik heb hetzelfde probleem verholpen nadat ik de wijziging in de beveiligingsinstellingen van mijn Gmail-account had aangebracht door 'Toegang voor minder goed beveiligde apps' van www.google.com/settings/security toe te staan. De gerelateerde nuttige link kan worden gevonden hier


Om dit probleem op te lossen, moet u:

1) Log in op uw Gmail-account met behulp van de webbrowser.

2) Klik op deze link om applicaties toegang te geven tot uw account: https://accounts.google.com/b/0/DisplayUnlockCaptcha

3) Klik op de knop Doorgaan om de stap te voltooien.

4) Probeer het nu opnieuw om de e-mail vanuit uw PHP-script te verzenden. Het zou moeten werken.


3
2018-01-09 10:31



Dit is misschien niet echt een antwoord voor een linux core-installatie. En ik ben er niet helemaal zeker van dat dit zal blijven bestaan ​​nadat de daemon opnieuw is opgestart. Je bent beter af de onveilige app-instructies volgen. - Reaces
Het werkte voor mij. Linux kerninstallatie. Ik heb ingelogd vanaf een andere computer. - Michal Sokolowski


Dit komt omdat Google onlangs een beleidswijziging heeft geïmplementeerd, die naar eigen zeggen deel uitmaakt van een reeks wijzigingen om de e-mailverificatie te versterken en een eind maakt aan alle praktijken van Google-producten die de verificatie schenden.

Er worden veel opties voorgesteld, zoals het wijzigen van de poorten voor de smtp-server, om de optie "minder veilige apps toestaan" in het tabblad Beveiligingsinstellingen enz. In te schakelen.

Een oplossing die werkt, is om de authenticatie in twee stappen van Gmail voor de AuthUser in te schakelen, een app-specifiek wachtwoord te genereren en dit wachtwoord te gebruiken als het wachtwoord van Gmail bij het instellen van de optie "Send mail as". Zodra u een app-wachtwoord hebt gemaakt en deze hebt gebruikt /etc/ssmtp/ssmtp.conf, op AuthPass=, kunt u tweestapsverificatie uitschakelen zonder tweestapsverificatie in te trekken.


1
2017-08-31 15:34





Heeft u de verstrekte link gevolgd en de instructies gelezen? Dit is hoe het te repareren.

Ik wed dat je de verkeerde gebruikersnaam of wachtwoord hebt ingevoerd.

Als ze echt correct zijn, controleer dan of u dezelfde poort gebruikt. Hierboven hebt u 587 gespecificeerd, terwijl hieronder u 25 hebt gespecificeerd.

Dan is het waarschijnlijk niet OK om te specificeren UseTLS en UseSTARTTLS. Gebruik op poort 587 UseTLS, gebruik poort 25 via UseSTARTTLS.

Op het einde is uw hostnaam niet "mailserver". Gebruik een FQDN.


0
2017-10-10 17:36



@ mmailq, Per uw oplossing heb ik de poort nr. naar 587 op zowel het conf-bestand gewijzigd als ik ben er zeker van dat de gebruikersnaam en het wachtwoord juist zijn. - Connect
@@ mmailq, wat moet de FQDN zijn? mijn serverhostnaam is mailserver. - Connect
@@ mmailq, nee het werkt niet dezelfde fout komt eraan. - Connect


Ik heb dit opgelost door een nieuw GMail-account te maken, alleen voor het verzenden van e-mail, het activeren van de tweefasenauthorisatie en het genereren van een app-wachtwoord.

Het werkt als een charme!


0
2018-03-05 07:46