Vraag Wat betekent dat: pakketten die zijn uitgesloten vanwege beschermingsmaatregelen voor opslaglocaties


Bij het updaten met yum ontvang ik het volgende bericht:

yum update
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * atomic: www7.atomicorp.com
 * base: mirror.de.leaseweb.net
 * extras: mirror.de.leaseweb.net
 * updates: mirror.de.leaseweb.net
118 packages excluded due to repository priority protections
Setting up Update Process
No Packages marked for Update

Wat betekent dat ? Hoe deze pakketten te installeren?


53
2017-09-17 09:27


oorsprong




antwoorden:


Sommige pakketten worden door meer dan één repository beheerd. De priorities plugin kiest u pakketten uit de repository met de hoogste prioriteit, met uitzondering van dubbele vermeldingen van andere repo's.


33
2017-09-17 09:53





Van wat ik begrijp, wordt deze fout gegenereerd door de priorities plugin zoals opgemerkt door Pawel.

In 2009 heeft de beheerder van yum genoemd dat hij hoopte dat mensen het niet zouden gebruiken priorities. Om de prioriteiten-plug-in uit te schakelen, bewerk /etc/yum/pluginconf.d/priorities.conf En instellen enabled = 0. Na deze wijziging, de volgende keer dat je rent yum update, je zou geen prioriteitsbescherming moeten krijgen.


47
2018-06-26 17:33



Ik heb me aangemeld om dit te bespreken. Mijn openssh is niet bijgewerkt naar de nieuwste versie omdat de prioriteitsinstelling is ingeschakeld. Dit heeft me geholpen. Bedankt! - manish_s
Ja, de 'set enabled =' werkte voor mij. Het zou leuk zijn om meer informatie van yum te pesten - zoals de namen van de betreffende pakketten en de opslagplaatsen waar ze vandaan komen. (Is dit een afzonderlijke vraag?) - bobgus
EEN yum erase yum-plugin-priorities werkt ook. - mbirth
U kunt de plug-in ook uitschakelen yum's command line met deze regel: --disableplugin=priorities - KJH


Als u wilt weten welke pakketten worden uitgesloten vanwege prioriteitsbescherming die u kunt gebruiken

yum list updates -d3

23
2018-04-23 16:45