Vraag Mount CIFS Host is offline


Ik heb een probleem met een koppelpunt dat eerder was geconfigureerd. Het toont de map, maar de mount ontbreekt en bevat "?" waarden voor grootte, rechten, etc.

Dus probeerde ik opnieuw te gebruiken met cif's en hetzelfde commando van voor:

mount -t cifs //nas.domain.local/share /mnt/archive

Maar ik krijg de foutmelding:

Host is down.

Als ik het domein of IP pings krijg ik een juiste resolutie en ik verbond ook gebruikend smbclient zonder kwestie

 ping nas.domain.local
 ping ip
 smbclient //nas.domain.local/share

Ik keek rond, maar kan geen solide antwoord vinden. Wat denk jij?


58
2017-08-03 17:13


oorsprong


is een nslookup nas.domain.local hetzelfde als het ip dat je hebt gepingd? - tony roth
Ja, het teruggezonden IP-adres is correct. Ik kan ook toegang krijgen tot de webinterface van de NAS via het IP-adres en domein. Ik heb toegang tot de gegevens op mijn laptop via het domein of IP, dus het lijkt erop dat hier een ander probleem speelt - Kevin
Voeg de toe --verbose schakel over naar je mount-commando, plaats eventuele fouten / resultaten die relevant lijken. - Zoredache
Werkt de service zelfs op de externe server? Het is een Linux of Windows Server? Als het Linux is ... controleer dan of de service actief is. Zorg ervoor dat er geen wijzigingen zijn aangebracht aan de firewall ... Als het Windows is ... dan zou je kunnen overwegen om opnieuw op te starten ... - Jay
@Zoredache toevoegen -vvv voor nog meer uitgebreid informatie! - Serge Stroobandt


antwoorden:


Dit kan ook het gevolg zijn van een niet-overeenkomende protocol. In 2017 heeft Microsoft Windows-servers gepatcht en geadviseerd om het SMB1-protocol uit te schakelen.

Vanaf nu kunnen mount.cifs problemen hebben met de protocolonderhandeling.

De weergegeven fout is "Host is down.", Maar als u fouten opspoort met:

smbclient -L <server_ip> -U <username> -d 256

je krijgt de foutmelding:

protocol negotiation failed: NT_STATUS_CONNECTION_RESET

Gebruik om dit te ondervangen mount of smbclient met een opgegeven protocol.

voor sbmclient: add -m SMB2 (of SMB3 voor de nieuwere versie van het protocol)

smbclient -L <server_ip> -U <username> -m SMB2

of voor mount: toevoegen vers = 2,0 (of vers = 3.0 als u versie 3 van het protocol wilt gebruiken)

mount -t cifs //<server_ip>/<share> /mnt/<mountpoint> -o vers=2.0

80
2018-04-05 08:30



Mijn NAS staat onder Linux als ik je oplossing probeer smbclient -L 192.168.1.47 -U admin -d 256 alles werkt perfect, maar als ik het probeer mount -t cifs -o username=aa,password=bb,uid=olivier //192.168.1.47/partagefichiers/ /mnt/PartageFichiers het blijft maar zeggen mount error(112): Host is down - Olivier Pons
Heb je geprobeerd het protocol te specificeren zoals ik uitleg in dit antwoord? Probeer vers = 2.0 of vers = 3.0 of vers = 1.0 (afhankelijk van deze NAS-instellingen) toe te voegen: mount -t cifs -o gebruikersnaam = aa, wachtwoord = bb, uid = olivier, vers = 2.0 //192.168.1.47/ partagefichiers / / mnt / PartageFichiers - Marcin P
Vreemd. De manpagina zegt dat vers=1.0is de standaard, maar ik kon mijn netwerkstation niet laten mounten voordat ik expliciet was geslaagd vers=1.0. - Hubro
Is het mogelijk om dat aan de Windows-kant te veranderen? Ik heb een stukje software dat deze optie doorstuurt naar cif's en de vers-optie niet kent, zodat deze niet wordt doorgestuurd. - Andrew Savinykh


Op archlinux na een recente pakketupdate, moest ik vers = 1.0 toevoegen aan mijn mount-opties. Ik maak verbinding met een oude centos 5-box en tot gisteren kon ik verbinding maken zonder expliciet een versienummer te vermelden.


32
2017-10-06 07:51



Bedankt, ik had hetzelfde probleem, maar ik weet niet welke upgrade dit nodig maakt. - Ben
Dit is echt een raar probleem. Hetzelfde is mij vandaag overkomen. Ik heb geprobeerd om smbclient en libwbclient te downgraden, maar het probleem bleef bestaan. Misschien is er iets op de server veranderd. Ik denk dat het ook CentOS is, ik hoop niet CentOS 5! Bedankt voor de oplossing :) - jPlatte
Ik moest dit doen voor mijn Fedora 26 systeem om toegang te krijgen tot een mount op mijn Synology NAS DS413j, mijn / etc / fstab heeft nu ", vers = 1.0" aan het einde van de options string en er is geen 'Host is down' foutmelding. - Neek


USB-stick op Fritz NAS toonde "Host Down" voor Ubuntu 17.10:

De versie definiëren (vers=1.0) werkte - hier is de volledige reeks:

sudo mount -t cifs -o vers=1.0,_netdev,username=<user>,password=<pwd>,uid=1000,gid=1000  //192.168.178.1/fritz.nas <local mountpoint>

8
2017-12-22 10:16



Alles werkte van binnenuit /etc/fstab cifs mount; na apt upgrade op mijn Ubuntu 16.04 gebeurde dit. Specificeren van de -o vers=1.0 deed het. Dank je - equivalent8


Sorry als dit een late reactie is (ik realiseer me dat het een oude thread is), maar ik heb net ontdekt dat er een andere mogelijke reden is waarom mount.cifs zou zeggen dat de host down is.

Ik heb een antivirus met een firewall en hoewel ik deze expliciet instelde om "Windows-bestand en delen van afdrukken" toe te staan ​​- een voorgedefinieerde regel, blokkeerde hij nog steeds verbindingen. Ik had dat bewezen door de firewall tijdelijk uit te schakelen. Ik hoop dat dit iemand helpt, de host down is, betekent misschien niet dat het niet reageert op pings, maar kan betekenen dat het niet reageert op authenticatiepogingen.


5
2017-11-28 22:48



Vergeet niet om de firewall aan beide kanten te controleren: client en server (evenals elke firewall die er mogelijk tussen zit). In mijn geval was het de firewall van de client die verbindingen met de server blokkeerde. Ik moest toevoegen iptables regels om hen toe te staan: iptables -A INPUT -s 1.2.3.4/32 -j ACCEPT en iptables -A OUTPUT -d 1.2.3.4/32 -j ACCEPT, waar 1.2.3.4 was het IP-adres van de server. - Antonio Vinicius Menezes Medei
Mijn NAS is op Linux, dus ik heb nog steeds dit probleem, maar bedankt voor het delen - Olivier Pons


Ik kreeg dezelfde foutmelding zonder verdere omhaal van een nieuwe Samba-client, toen ik probeerde een CIFS SMB-netwerkshare te koppelen:

mount error(112): Host is down

Uiteindelijk bleek dat ik de toegang tot SMB-servers tot voor kort beperkt had tot slechts een beperkt aantal IP-adressen door te configureren /etc/samba/smb.conf:

# Allow these IP Addresses to connect: 
hosts allow = 127.0.0.1 127.0.1.13 127.0.1.63

# Anything else not allowed is, by default, rejected
hosts deny = ALL

Het probleem werd in dit specifieke geval opgelost door het vaste IP-adres van de nieuwe SMB-client toe te voegen.

Natuurlijk zijn er talloze andere redenen waarom bovenstaande fout kan optreden.


4
2018-04-23 21:47





Gelijksoortig probleem na upgrade naar ubuntu 17.10, met een oud Buffalo Diskstation. Opgelost door / etc / fstab toe te voegen de "vers = 1.0" optie:

// myWDhostname / partage / media / Partage cifs guest, vers = 1.0 0 0


2
2018-03-04 14:12



Iedereen die Ubuntu 18.04 gebruikt, voegt het toe ,vers=1.0 optie lost het probleem op bij het gebruik van de tutorial geleverd door Ji m op ubuntuhandbook.org/index.php/2014/08/... - Geppettvs D'Constanzo
Ik heb hetzelfde probleem en kan het oplossen door versie 1 in de protocoll te gebruiken. Maar ik heb een zeer lage overdrachtssnelheid van gegevens. Ik vermoed dat dit misschien te wijten is aan versie 1, dus een andere versie gebruiken zou beter zijn. - Ben


De SMB1-versie van het protocol is verouderd, maar dit is de standaardversie die wordt gebruikt in oudere versies van mount.cifsb.v. Ik heb dit probleem met versie 6.2.

U kunt contact opnemen met: sudo mount.cifs --version

Als u probeert verbinding te maken met een SMB3-server met behulp van het SMB1-protocol, krijgt u de Host is down fout.

De oplossing, zoals beschreven door vele andere antwoorden, is om een ​​andere versie van het protocol op te geven. De volgende opdracht werkt voor mij: sudo mount -t cifs //server.name.or.ip/shares/Public /target/directory -o username=someuser,domain=somedomain,vers=3.0

Echter, als de server waarmee u verbinding maakt, DFS gebruikt, krijgt u in plaats daarvan de volgende foutmelding: mount error(38): Function not implemented. Dit komt omdat DFS-ondersteuning alleen op SMB3 was toegevoegd aan de kernel in versie 4.11.

Je kunt je kernelversie controleren met uname -a. In mijn geval was het 3.10 op CentOS7. ik volgde deze instructies om te upgraden en nu werkt het.


2
2017-09-04 08:43





Hetzelfde probleem met Fritzbox 7490: mount error (112): host is uitgeschakeld

Ik heb niet gebruikt -o vers = XX. Zo snel als een haai ik ben, heb ik eerst geprobeerd -o vers = 2.0 en mislukt.
Zodra ik de optie gebruikte -o vers = 1.0, alles werkt goed!

Dit werkt voor mij ..

 sudo mount -t cifs -o rw,username=myname_on_the_box,pass\word=mypasswd_on_the_box,vers=1.0 //192.168.1.1/Fritz-nas /media/something/something    

Mijn env:
Client: Ubuntu 17.10 Linux 4.13.0-17-generiek # 20-Ubuntu SMP x86_64 GNU / Linux
Server: Fritzbox 7490-firmware 6.83.


1
2017-11-30 11:53



AVM gebruikt een verouderde versie van Samba die ze zelf onderhouden. Dat verklaart waarschijnlijk waarom je moet gebruiken vers=1.0 in plaats van de meer geschikte nieuwere protocolversies. - 0xC0000022L


Hetzelfde probleem bij het verbinden met Synology DiskStation (DSM 4.3).

Het gebruik van vers = 1.0 in de bevestigingsopties werkt prima.

Daarnaast moest ik de optie "noperm" gebruiken omdat alle bestanden ten onrechte als niet leesbaar en beschrijfbaar door de eigenaar werden getoond.


1
2017-12-05 10:58





Ik gebruik dit type commando meestal om een ​​cifs / smb share te mounten.

mount -t cifs -o rw,netbiosname=nasserver1,credentials=/etc/user_credentials.txt //192.168.1.11/someshare /mnt

het inloggegevensbestand ziet er zo uit:

username=mydomain\user1
password=somepass

Dit kan ook worden aangepast aan een automount-opstelling, zodat het monteren / demonteren door het systeem automatisch via autofs kan worden afgehandeld.


0
2017-11-04 07:23





In ons geval controleerde ik de inlognaam van de gebruiker (van gebruiker2) in de AD. Daar merkte ik dat de naam begon met een hoofdletter en veranderde het in kleine letters zoals het is geschreven in het mount-script. Zelfs als we noch user2 noch het mount-script eerder hadden aangeraakt, was de mount-opdracht plotseling succesvol.

mount --verbose -t cifs //pc/share /my-share -no user=user1,password=pw1 -o uid=user2,gid=group1,dir_mode=0775,file_mode=0664

0
2018-06-29 11:28