Vraag OpenBSD / FreeBSD Firewall met GUI die compatibel is met Intel 82574L Gigabit LAN NIC's


Ik heb onlangs een server gekocht om m0n0wall of pfSense uit te voeren, maar ik heb sindsdien geleerd dat beide firewallproducten gebaseerd zijn op versies van FreeBSD die nog niet compatibel waren met de netwerkkaarten op mijn nieuwe server.

De SuperMicro-server die ik heb gekocht, heeft dubbele Intel 82574L Gigabit LAN NIC's en ik zou graag een manier vinden om een ​​firewall op te installeren die firewallbeheer zal vereenvoudigen door het gebruik van een GUI.

Ik weet dat ik gewoon pf kan gebruiken, maar omdat we graag een GUI-frontend willen hebben, wat zijn onze opties? Moet ik deze server retourneren en een leverancier zoeken die oudere hardware verkoopt die compatibel is of kan ik deze hardware op de een of andere manier laten werken?


8
2017-07-06 16:49


oorsprong


Heb je geprobeerd om pfsense / m0n0wall te vragen als ze van plan waren de stuurprogramma's bij te werken? - pauska
Lijkt erop dat pfSense 8.1 traint voor hun aankomende 2.0-release. De EM-driver werd in februari geüpdatet door Intel en maakt deel uit van versie 8.2. Ik stel me voor dat pfSense enige tijd nodig zal hebben om bij te praten; het is misschien mogelijk om in de nieuwere kernel te wisselen zonder veel te breken, maar ik heb het niet geprobeerd. - Chris S


antwoorden:


pfSense 2.0 heeft Intel-stuurprogramma's van FreeBSD 9 teruggezet, dus dat zal zeker werken, en is in het algemeen toch de voorkeursversie voor nieuwe implementaties. m0n0wall snapshot-versies zouden ook moeten werken.


6
2017-07-07 01:46





M0n0wall snapshots (ontwikkelingsversie) zijn momenteel gebaseerd op 8.2 en dienen uw NIC's te ondersteunen.

U kunt ook een volledige installatie van gebruiken FreeBSD met Webmin voor de GUI. Ik heb Webmin niet op FreeBSD gebruikt, dus ik kan niet getuigen van de volledigheid van de interface zoals pfSense of M0n0wall.


2
2017-07-06 17:17





Als de huidige pfsense of monowall dit niet doen en u geen bètaversie wilt uitvoeren of een kandidaatversie wilt vrijgeven, kunt u het nieuwste freebsd of OpenBSD en gebruiken Firewall Builder. Je krijgt niet alle extra's die monowall of pfsense bieden, maar als alles wat je wilt een firewall is, zal het werken.


1
2017-07-07 02:48





Je zou er altijd een hypervisor onder kunnen zetten (ESXi gratis zal zeker werken met een 82574, en pfsense 2.x zal werken met de Intel-emulaties die ESXi biedt :). Maakt ook upgradebeheer / testen eenvoudig ...


0
2018-05-05 23:45