Vraag Debian 8: Geen LSB-modules beschikbaar


Wanneer ik ren lsb_release op Debian 8 is de volgende fout opgetreden:

No LSB modules are available.

Ontbreekt er een bestand aan dit probleem?


8
2017-11-25 08:51


oorsprong




antwoorden:


Zoals de foutmelding zegt lsb_release opdracht is geïnstalleerd maar lsb module is dat niet. Gebruik deze opdracht om het probleem op te lossen:

apt-get install lsb-core

Ik stel voor om te gebruiken lsb_release -a in plaats van lsb_release. Het toont meer nuttige uitvoer.


15
2017-11-25 08:56



Dit werkt niet op mijn debian-baan. Nog andere ideeën? - QILIN LU
Wat is het probleem? je kan lsb-core niet installeren of loopt ip fouten veroorzaakt? - SuB
@SuB On Stretch lsb-compat is in plaats daarvan geïnstalleerd als vervanging voor lsb-core en nadat dit is geïnstalleerd, verandert het niets. lsb_release -a nog steeds uitgangen No LSB modules are available. (samen met de uitgezonderde bruikbare uitvoer, dus het is niet echt een probleem, maar nog steeds irritant). - kayahr
Op Ubuntu 18 lsb_release -cs werkte, dan hield het vreemd op. ik installeerde lsb-core en het werkt als een vlinder, ty. - JREAM